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Architect Overview
ORIGAM Architect is a modeling tool used to develop ORIGAM applications. Using Architect you can model the
following functionality:
>
>
>
>

Data Model
Business Model (validations, workfows...)
User interface
API

Architect UI consists of docked windows and documents, like most of integrated development environments
(IDE's).

Diferences to Traditional Development
Modeling in Architect is completely different approach to the traditional development. ORIGAM model is a
domain specifc language (DSL) for creating enterprise applications that typically contain data, forms, UI
validations, workfows and API's.
In traditional development you have to create a kind of a framework for each application you develop (function
libraries, common classes etc.). With ORIGAM you have the basic building blocks encapsulated inside the
model and you just express your requirements using the model. ORIGAM Runtime then takes as much care as
possible to bring your requirements to life.
As for enterprise applications we tried to take all the best practices into the ORIGAM platform so you do not
have to take care anymore about common stuff like writing proper SQL, application deployment, workfows etc.
Now you need to think about WHAT your customer needs instead of trying to fnd out HOW to do stuff from
day one.
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Development Environment
ORIGAM Architect consists of the following basic elements:
>
>
>
>

Menu
Toolbar
Documents
Docked Windows
Toolbar

Menu

Document

Docked Window

Docked Window Tab

Menu
Menu contains all the commands you can use inside Architect.
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Toolbar
The toolbar contains few basic commands and a search box for searching the model.
Saves currently opened document
Saves the model to the repository

Documents
Any data you will edit using Architect will be opened as a document. These are typically model editors or tools
like Deployment Script Generator, settings editor, etc.
You can switch between the documents using tabs or you can close them using small black cross.

Docked Windows
Windows docked to the sides of Architect contain different tools for working with the model such as
>
>
>
>
>
>

Package List
Model Browser
Properties
Find Results
Output
Documentation

You can move docked windows as you wish inside Architect by dragging them around. If you close them, you
can open them again using menu View.
By double-clicking on the docked window header you undock the window. By double-clicking again you put the
window back to the dock.
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Package List
Packages are the main containers of model elements. Here you can create, delete or open packages.Model
Browser
In the Model Browser you see all the elements in the current package and all imported packages.
Elements in the current package are displayed in black color whereas imported packages are displayed gray.
By double-clicking on the model element you open its editor.
Properties
Some model editors use the Properties window to edit different properties. The example is a Form editor which
uses this window to edit properties of different components placed on the form.
Find Results
This window displays results from using the search box or from exploring model dependencies. By doubleclicking on the result you will be navigated to the selected element in the Model Browser.
Output
In this window you can see output of different tools. It can be a live application log or preview of generated
SQL statements, XML fles and other textual information.
Documentation
Using the Documentation window you can document the model. Some of the documentation will be used in
the generated documentation and some can even be used in the fnal application, e.g. for displaying text in
tooltips.
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Model Contents
ORIGAM model consists of all the building blocks of an application. Every part of the solution is modeled and
later interpreted by the ORIGAM Runtime.

Common Model
In the Common section of the model you can fnd general elements that you will need throughout the modeling
process of your application.
Common model has the following parts:
Deployment

Deployment model allows you to defne model versions and database upgrade
scripts between those versions. Deployment scripts will get executed when you
deploy a new version to the customer.

Features

Features allow you to defne parts of the model that can be unlocked by allowing
the feature by the user. This is handy e.g. for defning BETA features that will not
be visible to a customer unless he turns such a feature ON.

String Library

To allow full localization of the model to different languages, error messages and
other texts can be stored in the String Library. When defned here, those
messages can be localized.

Data Model
Data model is at the lowest level in the modeling process. It is the basic part of the resulting application. After
the data model is defned all following modeling makes use of it. For example when designing screens the
editor offers list of data felds so you can just drag and drop to the form designer.
Data model has the following basic parts:
Constants

Data constants allow you to store different constant values that will be used
elsewhere in the system, e.g. for defning conditions.

Data Structures

When Entity model defnes the basic data entities, Data Structures defne the
structures of the screens, API's and workfow contexts. With Data Structures you
also predefne flter sets, sort sets and rule sets to be used later with the
structure. Data Structures are built on top of entities and use them to get list of
felds, basic flters, etc.

Entities

Entity model is the most important part of the ORIGAM model. It defnes data

® 2014 Advantage Solutions, s. r. o.

7

ORIGAM Architect

Getting Started Guide
entities which in turn defne database tables for storing customer data. Entities
contain not only felds but also predefned flters, row-level-security rules, rowcolor rules and others.

Functions

Functions defne a set of functions you can use for modeling data flters or simple
calculated entity felds. You can add your own database functions (that you
create manually in the database and map using this part of the model).

Lookups

Lookups defne the way how to fll-in combo-box lists and how to translate id's to
names both in the user interface and business logic.

Tree Structures

Here you can defne hierarchical structures that you can later use in the user
interface.

User Interface Model
You will use the user interface model to model ORIGAM GUI. That is to model a user interface that will be
displayed by the ORIGAM client application.
Dashboard Widgets

Dashboards Widgets are predefned parts (e.g. charts, tables, values) that users
can later add to their dashboards.

Charts

Defnition of charts for the UI.

Images

List of images that can be used as menu or action button icons.

Keyboard Shortcuts

List of keyboard shortcut defnitions that can be assigned to action buttons.

Menu

Defnes the hierarchical user menu in the client application.

Notifcation Boxes

With notifcation boxes you can defne content of notifcation boxes at different
places in the application.

Reports

Reports model allows you to assign either internal reports (e.g. Crystal Report
fles) or web reports (external reporting systems URLs).

Screen Sections

Screen section is a predefned UI block on top of a single entity. It can contain all
the editable felds from the entity.

Screens

Screen is a set of screen sections (e.g. in a master-detail scenario).

Styles

Lists possible styles that can be assigned to widgets inside the screen designer.
The list is fxed for now.

Widgets

List of possible widgets that can be used for building the ORIGAM GUI. It also
lists all screen sections since these are considered as widgets in the screen
designer.
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Business Logic
This part of the model brings the application “alive”. Validations, state and user workfows, functionality—all
is defned in this part of the model.
Rules

XPath expressions or XSLT scripts that are used in the following parts of the
model:
> Validations
> Sequential workfow conditions
> Row-level-security conditions
> Conditional formatting conditions
> State transition conditions
> Calculated felds

Sequential Workfows

Defne the functionality of the application. They can be called from:
> Menu (for creating Wizard-like interfaces)
> Screens (using action buttons)
> Data events (record created/updated/deleted)
> State workfow events (changing states)
> Work Queue Actions
> API
> Other sequential workfows

Services

Lists available service agents that can be called in sequential workfows. You can
also write your own agents to connect with other services.

State Workfows

State workfows defne states and allowed transitions between them on an
entity-feld level. By defning a state workfow on a feld the feld gets checked for
state rules and starts producing state events.

Transformations

XSLT Transformations that can be used in:
> Sequential workfows (using Transformation Service)
> API (transforming raw-data)

Work Queue Classes

Defne a data structure of a work queue and possible actions on the specifed
work queue class.
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API
This part of the model allows you to defne REST API methods for your application or to directly create web
pages.
Name

Description

Web API/Pages

Here you can defne API methods that will face out your application. Using API's
it is possible to:
> Read data in different formats (XML, JSON, CSV...)
> Create web sites (delivering data in HTML)
> Write back data (XML, JSON)
> Execute sequential workfows
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TimesheetApp Tutorial
In this tutorial you will learn how to create an application in several steps.

Analysis
The application will consist of a form with the following sections:
>
>

Project
Time-sheets

Summary
In this tutorial you will learn how to:
>
>
>
>
>

Create a package
Create a simple data entity
Create database scripts and execute them
Create a screen and a menu item
Create a screen fow
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Creating a Package
Model consists of packages, so we begin with creating one.
1.
2.
3.
4.

Open ORIGAM Architect
In the Packages window click on Add button
Enter the name of the project “TimesheetApp”
Click OK

Now an empty package is created and loaded.
Note there are already elements in the package. That is because AsapRoot package was automatically
referenced.
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Creating a Project Entity
The frst thing to be created is a data model. It is the most basic part of the application.
First we will create the Project entity for storig project data.
We will also allow data auditing.
1. Open Data > Entities > TimesheetApp folder
2. Right click and select New > Database Entity
3. Enter “Project” into the Name feld and also to the
Caption feld
4. Set IsAuditingEnabled to True
5. Click the Save button in the toolbar
Please note that the entity has already some felds thanks to
the IAsapEntity2 entity from which we automatically
inherited.
Now add the following felds by repeatedly right-clicking on the Project entity and selecting New > Database
Field:
Name

Data Type

AllowNulls

Length

Caption

Name

String

False

200

Name

EstimatePrice

Currency

True

Est. Price

EstimateTime

Float

True

Est. Time (h)

Description

Memo

True

Description

Save the model.

Generating a Database Script
After the entity is modeled you have to create the corresponding table in the database. You do this using the
Deployment Script Wizard.
Deployment scripts will get executed when you deploy a new version to the customer. The scripts can contain
database commands or fles to be restored to the target server.
1. Choose Tools > Deployment Script Wizard from the menu
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2. Mark the checkbox at the Project entity
3. Click on the Add to Deployment button
4. Answer Yes to the question if you want to see the generated scripts in the search results.
5. Double-click on the item in the search results and you will see the script highlighted in the Model
Browser.
6. Right-click on the script item and choose Execute.
7. Now the Project table has been created in the database.
Save the model.

Creating a Menu
Before you can start creating a user interface you have to create a single menu in the Menu model. Not all
packages have to contain a menu (consider them libraries) but fnally you will have to create one if you want to
use ORIGAM GUI.
1. Right-click on the User Interface > Menu and select New > Menu
2. Call it simply “Menu” and set DisplayName property to “Menu” as well.
3. Click the Save button in the toolbar
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Creating User Interface
The last step in developing a simple application is to create the user interface, which will consist of a single
menu item which will open a screen with an editable table.
1. Right-click on the “Project” entity and choose Actions > Create Menu Item...
2. Now choose the felds you want to display in the UI. Set “Role” to * since for now we do not want to
create security roles.

3. Press OK.
4. In the Find Results docked window you will see the list of model elements that were now created for
you automatically.

5. Double-click on the screen section so you can fx the feld order, sizes etc.
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6. Use Ctrl+Shift+T to fx a tab order (by clicking one-by-one on the widgets).
7. Click on the Description feld and use the Properties (F4) docked window to set the Multiline
property to True.
8. Change the menu item's name to “Projects”.

See the Results
As the fnal step you can review the results by running your application.
1. Make sure to have DefaultSchemaExtensionId set in your AsapSettings.confg fle. The value
must be an Id of your package. To see your package id right-click on the top-level node TimesheetApp
in the Schema Browser docked window and select Edit …. Copy the value from the Id feld and paste
it into AsapSettings.confg.
2. Restart the IIS application pool
3. Open the application.
4. Open the menu Projects
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Using BusinessPartner Entity
When you look into the data database you can see there many existing tables. You can see these as entities
that you inherited from the Root model.
You will not directly use most of these entities because they are used by the infrastructure.
There is an exception from this–a BusinessPartner entity.
This entity has both infrastructure and custom use. It is used as
>
>

List of users with mapping to login user names
A base for an address book

The idea is that you will extend this entity with your custom felds (phone number, e-mail or any other
attributes you will see ft for your project's address book) and at the same time it will be used as your user
database (users are your business partners too).

Adding BusinessPartner Screen
Let's start with looking at what the BusinessPartner table contains and being able to add some data. You can
design your own screen by following the same steps as when you were creating a screen for a Project entity.

Creating a Foreign Key To BusinessPartner
Now it would be nice to be able to pick a business partner in our project. We can do this by:
>

Adding a foreign key feld to the Project entity that will link to the BusinessPartner

>

Adding a drop-down widget to your Project screen

Creating a Simple Screen Flow
A screen fow is a sequence of screens that you can present to a user, much like a Wizard kind of interface. In
order to create it you will create:
>
>
>
>

Sequential Workfow
Screens
XSLT Transformation
Menu Item
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Deployment Script

In the following chapters we will create a screen fow that will allow
the user to easily add a new project.

Creating Screens For a Screen
Flow
You can use any screen that you learned to create in the previous
chapters but we will make two screens that will be optimized for the
screen fow:
>
>

Customer Selection Screen
Single Project Entry Screen

Customer Selection Screen
We will base this screen on a BusinessPartner entity which became our system's address book and we will let
the user select one of the business partners as the project's partner.
1. Right-click on the “BusinessPartner” entity and choose Actions > Create Screen...
2. Then we will choose the felds that we want to display.
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3. Now we will add a checkbox that will allow the user to select the business partner for the new
project. Open the newly created BusinessPartner screen section and drag the Selected feld to the
section.
4. Click on all entry felds (Name, First Name, Selected) on the section and set the ReadOnly attribute to
True (Press F4 to display the Property Grid). We do not want the user to edit any of these felds while
in the wizard.
5. Save the screen section.
6. We will also need to hide the Add and Delete buttons on the screen sections so open the Business
Partner Screen, select the screen section on it and se the ShowNewButton and
ShowDeleteButton to False.
7. Rename the screen to BusinessPartner_Selection and save the screen.
Project Entry Screen
In the project entry screen we will reuse the screen section for the project entry we already created. We will
just make it displaying in the Detail View by default and we will hide the Navigation Panel because when
entering a single project we do not need one.
1. Right-click on the existing “Project” screen section and choose Actions > Create Screen...
2. This will immediately open a new screen based on the selected screen section.
3. First rename the screen to ProjectEntry.
4. Then select the section on the screen and set HideNavigationPanel to True. Also set the
ShowNewButton and ShowDeleteButton to False.
5. Save the screen.
Now we are done with preparing the user interface for the screen fow.
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Creating a Sequential Workfow
In order to see the screens displaying one by one we need to create a Sequential Workfow.
Sequential workfows can be use to implement business logic's functional fows but also to create screen
fows. By assigning a sequential workfow to a menu item we will get a screen fow.
Step 0: The Sequential Workfow
Now we will create a new sequential workfow and defne some Context Stores.
A Context Store is much like a Variable in a traditional programming language. We will use a context store to
store the data which the sequential workfow will manipulate.
1. Right-click on the “Business Logic > Sequential Workfows” model part and select New > Sequential
Workfow
2. Name it “ProjectEntry”
3. Set the TraceLevel to TraceClientAndArchitect so we can later debug this workfow.
4. Save the workfow.
5. Right click on the newly created workfow and select New > Context Store.
6. We will use an existing data structure BusinessPartner, so select one from the DataStructure list.
7. Save the context store.
8. We will ad one more context store that will be based on the Project data structure (repeat steps 5 to
7).
Step 1: Loading Business Partner List
As we said the frst step would be displaying a list of
business partners and letting the user select one. So the frst
thing to do is to actually load the list from the database.
1. Right-click on our workfow and select New > (Task)
Service Method Call.
2. Select a Service DataService, Method LoadData
and OutputContextStore BusinessPartner. That
means we will use a DataService.LoadData to fll in
the BusinessPartner context store.
In case you do not want all the data from the database you need to specify a flter and eventually a
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sort order. In that case right click on the DataStructure under the task and select New > Data
Structure Reference and defne your own parameters.
Step 2: Business Partner Selection Screen
After we have a list of partners loaded we can present them to the user so he can select one.
1. Right-click on our workfow and select New > (Task) User Interface.
2. Select a Screen property to BusinessPartner_Selection and
OutputContextStore BusinessPartner. This way the wizard
will show our selection screen and will use data we loaded in
the previous step.
3. Since this is a second step, we need to tell that to the engine.
Right click on this step and select New > Dependency and
select the frst step in the Task property.
Step 3: Preparing a New Project Record
Now the user selected a record using a checkbox we want to pass it as a new value to an XSLT transformation
that will prepare a new Project record for us. For that we will add a third step.
First we will prepare an XSLT transformation:
1. Right-click on the “Business Logic > Transformation” model part and select New > XSL
Transformation (XSLT).
2. Name it Project_New and add the following as the transformation body:
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"
xmlns:AS="http://schema.advantages.cz/AsapFunctions"
xmlns:date="http://exslt.org/dates-and-times" exclude-result-prefixes="AS date">
<xsl:template match="ROOT">
<ROOT>
<xsl:apply-templates select="BusinessPartner[@Selected='true']"/>
</ROOT>
</xsl:template>
<xsl:template match="BusinessPartner">
<Project
Id="{AS:GenerateId()}"
Name="{@Name}"
refBusinessPartnerId="{@Id}"
DueDate="{date:date()}"
/>
</xsl:template>
</xsl:stylesheet>

The transformation will go through each selected business partner and create a new project with a
preselected business partner, name and due date (which is a mandatory feld so it has to be flled
otherwise we would get an error after the transformation would be processed).
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Then we will add the transformation step to our screen fow:
1. Right-click on our workfow and select New > (Task) Service Method Call.
2. Select a Service Data Transformation Service, Method Transform and OutputContextStore
Project. That means we will be generating data into the Project context (which we will display to the
user in a screen in the next step). Name it 03_NewProject.
3. Save the element.
4. Right-click on the 03_NewProject and create a new dependency on task 02.
5. Now we will set the Data and XslScript parameters of the transformation step:
a) Right-click on the Data parameter and select New > Context
Store Reference.
b) Choose the BusinessPartner context and save the element.
c) Right-click on the XslScript parameter and select New >
Tranformation Reference.
d) Choose the Project_New transformation you created earlier
and save the element.
Step 4: Displaying the Project
1. Repeat Step 2 but now with the ProjectEntry screen you created earlier.
2. Don't forget to create a task dependency on the previous step.
Step 5: Saving the Project
1. Repeat Step 1 but now with DataService method StoreData.
2. Don't forget to create a task dependency on the previous step.

Testing the Screen Flow
You can always test what you did by right-clicking on the sequential workfow and selecting Execute (Ctrl+X).
Always check the Output pad for information about what is going on. If error occurs you can also see exactly
what went on by selecting Tools > Show Trace (Ctrl+T). There you can look up the instance you executed
and see the data that were intput and output for each step.
Important: You should turn off the tracing for production deployments because it creates excessive data.
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Creating a Menu Item
Now when the sequential workfow is ready you need to assign it to a menu so the user can execute the
screen fow. You can do this easily by right-clicking on the sequential workfow and selecting Actions >
Create Menu Item. It works the same way as when you were creating your frst screen–it creates a
Workfow Reference Menu Item (which you can then re-order as needed in the menu structure) and an
application role (with a deployment script for inserting the role into the database in case you selected a role
different than *).
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